Troubleshooting

Ubuntu >= 18.10 as an requirement:

Ubuntu version 18.04 and prior: Cura >= 4.0, which is delivered via “stable” PPA, is not supported on Ubuntu bionic. Please upgrade to Ubuntu 18.10 (cosmic) at least! The reason is described in two issue reports on Github. One report tells you why Cura >= 4.0 won’t run on Ubuntu bionic or prior versions and the other why a downgrade to the previous version is also no option.

Downgrading all packages and removing the PPA:

There is a separate page with all instructions.

Can’t find feature XY that’s usually included in Ultimaker’s Cura

Plugins are now usually distributed using Marketplace or previously known as Toolbox. Just take a look at Cura closely. You should be able to find the marketplace easily!

Ultimaker 3 Connect button is missing

You probably need to add the plugin for UM3 network printing. You can install cura-extra-plugin-um3networkprinting or all the plugins by installing cura-extra-plugins-all.